Details

    • Type: Bug
    • Status: Resolved
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 1.6.0b1
    • Fix Version/s: 1.6.0b2
    • Component/s: None
    • Labels:
      None

      Description

      I went to download KSEA from the gateway so I could look at the service vehicle routes and in the process of selecting KSEA, the app quit. I did not get far enough to have a xml file open. I am using windows 10.

        Issue Links

          Activity

          meikelm Michael added a comment - - edited

          Using the just a few hours ago released 1.6b1 under windows as well as linux ...
          I can download the recommended version from the gateway just fine and save it.
          Upon re-opening the saved earth.wed.xml I do get a warning about corrupt content, it automatically deletes the protested items and then proceeds to open the rest as a seemingly fully useable scenery. Which appears to be error-resilience as intended.
          Windows and Linux versions behave identical in this respect.

          Keith,
          the gateway has XP 1050 format 2D scenery only for KSEA, there are no service routes in there at all. Please open the KSEA Demo Area scenery included in XP11 to see all that glory.

          gatewayapp Gateway App added a comment -

          [Gateway user bkeith posted:]
          Thanks Michael,

          Since that one crash I have not had any issues with opening the file. My only issue now was the vehicles are not appearing. I am going to play a little more tonight.

          meikelm Michael added a comment - - edited

          Just an update -
          the KSEA 2D airport on the gateway in fact contains a line with a single node. Upon saving & re-opening the saved earth.wed.xml the WED 1.6 importer finds it, ignores this one line and then you have a fixed airport. So far, that is all working as intended - there will be buggy files out there and WED has to be able to make the best out of it.

          What's not so good - unlike the WED 1.5 validation, WED 1.6 validation finds and complains about it. But there is no way to select and delete the protested item. So that's a bug I am going to fix.

          meikelm Michael added a comment -

          Actually, upon closer inspection, the validation does allow to delete the invalid line it finds just fine
          Its just - you cannot zoom to it to verify what is being selected, because a line with a single node draws nothing on the screen. So all I did was to extend the validation error message to encourage the user to just delete what the validation - correctly - already selected. Its the same approach we follow in validating and fixing duplicated nodes.
          commit 7196f8ea692c986b4f7dfbe9948e4ea43d03329b into wed_160_release


            People

            • Assignee:
              meikelm Michael
              Reporter:
              gatewayapp Gateway App
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: