Details

    • Type: Bug
    • Status: Closed
    • Priority: Very High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      When importing a .dsf, after importing also a apt.dat file, selecting the "folder" of the dsf file crashes the program.

        Issue Links

          Activity

          meikelm Michael Minnhaar added a comment - - edited

          I'l like to help you, but you're not giving me enough information suitable to reproduce this. I need:

          • WED version
          • X-plane version the XSystem folder in WED is set to
          • operating system
          • which apt.dat was imported from (every scenery has one, plus the XP global one)
          • which airport was imported
          • where to find the .dsf that was imported

          Please attach any of the files, unless they are part of the default X-plane installation

          meikelm Michael Minnhaar added a comment - - edited

          Got something possibly similar, but not neccesarily the same under Win7, but under Linux it works fine, does not crash.

          Import the apt.dat of XP11pb8 KSEA Demo Area, then the .DSF for the same scenery.
          Select in the hierachy pane the group created by he dsf import via mouse click.
          Crash.

          gatewayapp Gateway App added a comment -

          [Gateway user MadMat posted:]
          WED 1.6b1
          XP11
          Windows 10 x64
          It Happens every time I import an airport to fix some errors. The airport itself is ok, but when importing the dsf, after some moments wed hangs suddenly. Sometimes when selecting the folder of the just imported dsf.
          It seems it happens with big sceneries, and not with small ones.

          meikelm Michael Minnhaar added a comment - - edited

          MadMat,
          I still need the particular answers to my topics 4,5 and 6, as I did not see this behavior anywhere but at KSEA (and that one is fixed for the next beta). SO if it happens at some othe airport - I'm fairly certain it wont change for you in the next beta.

          gatewayapp Gateway App added a comment -

          [Gateway user MadMat posted:]
          Hi, the reply is simple, it happens at all airports. Now I tried witha x-plane.org LEBL (last version). apt.dat is imported correctly, and also the dsf, but, chicking on it...hangs wed.

          gatewayapp Gateway App added a comment -

          [Gateway user amelingu posted:]
          Hi, same crashed for me :
          -WED1.6.0b1
          -set to X-plane 11.00pb11
          -any 3d airport from the gateway, but not only

          It seems to be related with having a dsf imported, and also with browsing in the groups

          gatewayapp Gateway App added a comment -

          [Gateway user amelingu posted:]
          And I forgot to specify my computer details :
          Windows 8.1
          GTX970
          I5 processor

          gatewayapp Gateway App added a comment -

          [Gateway user amelingu posted:]
          And this crash is sometimes hard to reproduce. In my case, it's not always happening.

          gatewayapp Gateway App added a comment -

          [Gateway user MadMat posted:]
          To me it happens always. I'm waiting to this problem fixed cause I have 4 projects waiting!!!

          tgreene Theodore (Ted) Greene added a comment -

          A nightly build that contains a new tooltip fix which has fixed crashes like this.

          tgreene Theodore (Ted) Greene added a comment -

          Hi everyone posted here,

          Try this build (f486b43e31727106fe1a657a86b33d81208fb1a8) now attached to this bug. It contains a fix which fixed some mystery crashes.

          Also, what is the full file path to the earth.wed.xml?

          gatewayapp Gateway App added a comment -

          [Gateway user amelingu posted:]
          All right, I discovered your reply only now, as I didn't have any notification. Just tested it, the problem seems to be solved. Wonderful!!.
          About the path, there is no wed.xml because it is only when importing the apt then the dsf (to work in a team on a project for example) :
          E:\X-Plane 11\Custom Scenery\Airport_LFRF_essai\Earth nav data
          I tested as follows :
          WED 1.6.0b1 : crash
          WED_nightly_fix : no crash

          Thank you very much for your help and great support.

          tgreene Theodore (Ted) Greene added a comment -

          Tool tip fix seems to have solved people's problems.


            People

            • Assignee:
              meikelm Michael Minnhaar
              Reporter:
              gatewayapp Gateway App
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: